Matrox MXO User Forum Forum Index

 
 FAQFAQ   SearchSearch         RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

(MXO 2.1.5 BETA) ATI vs NVIDIA & Snow Leopard updates

 
Post new topic   This topic is locked: you cannot edit posts or make replies.    Matrox MXO User Forum Forum Index -> MXO
View previous topic :: View next topic  
Author Message
8lux
(MXO)




Joined: 04 Jul 2005
Posts: 13

PostPosted: Mon Dec 28, 2009 7:39 am    Post subject: ATI vs NVIDIA & Snow Leopard updates Reply with quote

Hello,

I was just curious why the MXO only works with certain SL updates for different graphic cards. Is it because of the beta-state of the MXO drivers? Or is it something in the SL updates that makes the MXO disfunctional if it's the "wrong" version?
In other words, will this be resolved with a new driver from Matrox? Or with a new SL update (that one probably only Apple knows)?
Any insight from you people at Matrox? Will I ever be able to update my Mac Pro with ATI card beyond 10.6.1?
(I'm still save on 10.5.8, just curious for the future...)

Bernie
Back to top
View user's profile Send private message
Matrox_Support_Mac
(Moderator)




Joined: 04 Jul 2005
Posts: 219

PostPosted: Fri Jan 08, 2010 5:27 pm    Post subject: Reply with quote

Hi,
Matrox has done all it can to resolve this issue. Hopefully it is up to a SL update to resolve this. We have our fingers crossed that this will happen soon Wink

-Mac


Last edited by Matrox_Support_Mac on Thu Jan 21, 2010 2:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
kwoff
(MXO)




Joined: 04 Jul 2005
Posts: 19

PostPosted: Sat Jan 16, 2010 2:50 pm    Post subject: Reply with quote

When you say "Matrox has done all it can to resolve this issue," what issue, exactly, are you talking about?

Thanks for any information you can provide.
Back to top
View user's profile Send private message
Matrox_Support_Mac
(Moderator)




Joined: 04 Jul 2005
Posts: 219

PostPosted: Mon Jan 18, 2010 10:33 am    Post subject: Reply with quote

Hi kwoff,
It was in response to this above question:
Quote:
I was just curious why the MXO only works with certain SL updates for different graphic cards.

The details of this are here: http://forum.matrox.com/mxo/viewtopic.php?t=2095

Best regards,
-Mac
Back to top
View user's profile Send private message
kwoff
(MXO)




Joined: 04 Jul 2005
Posts: 19

PostPosted: Mon Jan 18, 2010 11:37 am    Post subject: Reply with quote

Yes, I had seen this thread, but it doesn't describe any SL issue, it just says your drivers don't work under 10.6.2 with ATI cards. Your earlier post in this thread implies that there is a problem that Apple has a responsibility to resolve. Is this the case--if so, I am curious what that issue is.

Thanks
Back to top
View user's profile Send private message
Matrox_Support_Mac
(Moderator)




Joined: 04 Jul 2005
Posts: 219

PostPosted: Mon Jan 18, 2010 2:26 pm    Post subject: Reply with quote

Hi,
That issue described, is the issue I was referring to.

-Mac
Back to top
View user's profile Send private message
kwoff
(MXO)




Joined: 04 Jul 2005
Posts: 19

PostPosted: Tue Jan 19, 2010 5:30 pm    Post subject: Reply with quote

Matrox_Support_Mac wrote:

Unfortunately it is up to a SL update to resolve this it seems.


What I am wondering is why this issue requires a SL update, as you say, as opposed to an update to your MXO driver. Thanks for any information.
Back to top
View user's profile Send private message
Andy Mees
(MXO)




Joined: 04 Jul 2005
Posts: 1016

PostPosted: Tue Jan 19, 2010 11:20 pm    Post subject: Reply with quote

K.

The OS is a hardware abstraction layer ... what any developer can do to control the host hardware is defined by what control the OS's system calls allow of that hardware, and in turn that the host hardware will respond consistently to those calls regardless of the possible variations in component makes or models that make up that host.

The MXO drivers are reliant on the necessary Mac graphics hardware control being available such that the required data can be output via the DVI port to the MXO hardware ... in 10.6 / 10.6.1 system calls to Macs with ATI graphics chipsets produced the desired signal for correct operation of the MXO, but NVidia chipsets it seems did not respond to the same calls with the same result hence the MXO hardware did not receive the needed data; Apple's 10.6.2 update addressed many graphics related bugs and issues and appears to have addressed the inconsistencies revealed by the MXO when used with NVidia hardware, however it turns out fixing the NVidia issue seems to have simultaneously broken the ATI functionality! Ooops.

The good news in all this is that all MXO users now have the means to run their MXO's under Snow Leopard if wanted, regardless of the graphics chipset in their Macs, however that functionality is temporarily reliant on one using the version of 10.6 that supports the necessary control for ones graphics chipset. The bad news is that this isn't something that Matrox have any direct control over, so we have to wait for Apple to fix it and as ever, Apple are beholden to no one and do things on their own timeframe.

This is all my own take on the situation K, I'm not privy to any special info but there is some precedent to all this as a similar issue occurred with the MXO a few years ago. As for an official Matrox comment I would imagine strict non-disclosure agreements would prevent that.

Hope it helps
Andy
Back to top
View user's profile Send private message
SimonMW
(MXO)




Joined: 04 Jul 2005
Posts: 15

PostPosted: Wed Jan 20, 2010 12:34 pm    Post subject: Reply with quote

Does anyone know for definite that Apple are actually aware of the problem?
Back to top
View user's profile Send private message
kwoff
(MXO)




Joined: 04 Jul 2005
Posts: 19

PostPosted: Wed Jan 20, 2010 7:41 pm    Post subject: Reply with quote

Thanks for the explanation, Andy. The information in your post (which as you suggest, Matrox may not have been at liberty to provide) will allow me at least to register concern about the situation on the Apple feedback page.
Back to top
View user's profile Send private message
Matrox_Support_Mac
(Moderator)




Joined: 04 Jul 2005
Posts: 219

PostPosted: Thu Jan 21, 2010 2:47 pm    Post subject: Reply with quote

Thanks for your input and your insight, Andy. Surprised

Matrox is doing all it can to get it resolved. Hopefully this will all work out in the end.

Thanks for all your support.

Time for a lock-down. Smile
Best regards,
-Mac
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    Matrox MXO User Forum Forum Index -> MXO All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

This board is protected by Phpbbantispam
Powered by phpBB © 2001, 2002 phpBB Group