Matrox MXO User Forum Forum Index

 
 FAQFAQ   SearchSearch         RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

HDMI and SDI output track order

 
Post new topic   Reply to topic    Matrox MXO User Forum Forum Index -> MXO2 Family and Mojito MAX with Avid Media Composer Family (Mac)
View previous topic :: View next topic  
Author Message
Anonymous User
(MXO)

Guest





PostPosted: Mon Aug 08, 2016 10:23 am    Post subject: HDMI and SDI output track order Reply with quote

Hi,

I've been experiencing a strange phenomenon with both the MXO2 and Mini I/O devices.

It would appear that the digital audio track order on HDMI output is 1,2,4,3,5,6,7,8. (i.e. 3 and 4 are inverted).

This is in contrast to the SDI digital audio track order, which is (the expected) 1,2,3,4,5,6,7,8.

I have tested this by outputting a test 8 channel ident sequence from Avid via HDMI from both my MXO2 and MXO2 Mini into another Avid MC7.0.4 on Mac. Both invert tracks 3 and 4 on HDMI.

I've also output SDI from the MXO2 and compared it with the SDI output from a Blackmagic I/O device - both output SDI in the expected order 1,2,3,4,5,6,7,8.

Up until recently I've been using the MXO2 RCA analogue outputs for 5.1 audio (which are labelled correctly), so the issue hasn't arisen.

Is this normal behaviour for the HDMI track order to be reversed? I've been trying to find out on the web, but to no avail. If so, is it an HDMI standard.

I would be most grateful if someone could shed some light on what might be going on.

regards,

Andrew
Back to top
Anonymous User
(MXO)

Guest





PostPosted: Mon Aug 08, 2016 3:16 pm    Post subject: HDMI and SDI output track order Reply with quote

I think I may have stumbled across the answer in a previous post in a forum for the MC-100...

http://forum.matrox.com/mc100/viewtopic.php?p=629&sid=6032cd92cbc380d48db1326b8554c035

or briefly: "...The Matrox MC-100 has version 1.1 installed.

The unit is being fed an embedded 7.1 sound via HD-SDI. The SDI loop-thru (via MC-100) is being fed into a Blackmagic Ultrascope which confirms all the audio tracks are there and correctly mapped.

However, the HDMI output from the MC-100 feeds a NAD T748 amp which does not seem to show up tracks 3 & 4 correctly (ie. centre and subwoofer).

Infact, the two channels are swapped back to front from what we can hear (ie sub is on 3 / centre on 4)..."

The thread goes on and Sam appears to solve the issue with a new driver.

It seems likely that this is the same issue I'm experiencing with MXO2 and MXO2 mini.

So question: now that the product is nearing the end of being supported, what chance is there of updating the driver 4.0.6 to correct the HDMI channel order for use with Yosemite?

kind regards,

Andrew
Back to top
Anonymous User
(MXO)

Guest





PostPosted: Mon Aug 08, 2016 3:19 pm    Post subject: Reply with quote

...I mean the 4.6.0 driver !
Back to top
Matrox_Support_Sam
(Moderator)

Site Admin


Joined: 04 Jul 2005
Posts: 6879

PostPosted: Mon Aug 08, 2016 4:28 pm    Post subject: Reply with quote

Hi Andrews,

Are you referring to this documented issue in our Release Notes?
ftp://ftp.matrox.com/pub/video/doc/Matrox%20MXO2%20Release%20Notes_4.6.pdf

For surround sound HDMI audio output, Matrox MXO2 outputs the low
frequency effects (LFE) track on channel 3 and the center (C) track on
channel 4. However, if you capture the HDMI surround sound output from
MXO2 using Avid Media Composer/Symphony on another MXO2 system,
Media Composer/Symphony will assume that C is on track 3 and LFE is on
track 4. This means that the C and LFE channels won't be in the correct
order in your captured file. To play back and output your captured file
correctly on the MXO2 HDMI output, you can select Direct or Direct,
surround tracks in SMPTE order in the Audio Project Settings dialog
box to map track 3 to output channel 4 and map track 4 to output channel 3.
(Ref# VPG-1676)
_________________
Regards,
Sam
Matrox Video Technical Support
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Matrox MXO User Forum Forum Index -> MXO2 Family and Mojito MAX with Avid Media Composer Family (Mac) All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

This board is protected by Phpbbantispam
Powered by phpBB © 2001, 2002 phpBB Group